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                IT Tips and Tricks – no. 2 - Compression of Pictures
   
   IrfanView
   IrfanView is a compact, easy to use image viewer. More than that, you
   can also edit images directly in IrfanView, to produce a variety of
   effects. IrfanView was created by Irfan Skiljan.
   This 2nd issue of IT Tips & Tricks is about reducing the filesize of
   the pictures taken with the digital camera when pictures have to be
   prepared for e-mailing.
   The intention of e-mail pictures is to show the subject concerned
   clearly on the recipients screen, the pictures are not intended for
   printing, these usually much larger (in file size) pictures can by
   transferred to a floppy and mailed in the normal fashion if this is
   required.
   Pictures usually show a lot of detail which is of no interest to the
   receiver, for example in a large picture showing the damage to a piece
   of machinery, parts of the vessel, sky or quayside etc are of no
   interest but take up a lot of unnecessary file space. The picture can
   be manipulated in such a way that only the section of interest
   remains, reducing the file size considerable.
   Several tools are available for this purpose:
     1. 
       Cut and Paste – Edit menu
     2. 
       Crop – Edit menu
     3. 
       Resize/Resample – Image menu
     4. 
       Decrease Colour Dept – Image menu
     5. 
       Increasing the compression factor – File menu, Save as…. Followed
       by Options.
     1. 
       Edit Menu:
         a. 
           Cut
           Use the left mouse button to outline the area (selection),
           click on the Edit menu, then Cut (or use the Cut tool on the
           toolbar.)
             i. 
               Cut – selection
               The area inside the outline will be removed from the
               image. The cut portion is placed on the Windows Clipboard,
               and may be pasted in elsewhere. (e.g. in a Word document)
             ii. 
               Cut - leave selection
               The area outside the outline will be removed from the
               image.
               This action may be reversed with the Edit Menu's Undo
               command.
             iii. 
               Click on the Edit menu, then Paste (or use the Paste tool
               on the toolbar.)
         b. 
           Paste
             i. 
               If you have an Edit outline around an area of the current
               image, an image stored on the Windows Clipboard will be
               pasted into your outline. The Clipboard image will be
               re-sized to fit the outline, and the rest of the image
               will stay as it was. This feature is very useful for
               editing images or portions of them.
             ii. 
               If there is no Edit outline, an image on the Windows
               Clipboard will replace the entire image in the viewer, and
               therefore create a smaller picture with only the selected
               area which has been cut out of the original picture.
     2. 
       Edit Menu:
         a. 
           Crop
           Use the left mouse button to outline the area (selection),
           click on the Edit menu, then Crop.
           The area outside the outline will be thrown away, only the
           inside will be left.
           Use this to eliminate unwanted space or detail from an image.
           This action can greatly reduce the image size.
           It can also centre a badly composed photo.
           This action may be reversed with the Edit Menu's Undo command.
     3. 
       Image Menu:
         a. 
           Resize/Resample
           Click on the Image Menu, then Resize/Resample. A dialog allows
           you to choose the new size for the image; some Resample filter
           can be used if you are enlarging the image.
           There are several built in choices, or you can type over the
           old numbers. The first number is width, the second height,
           both in pixels. Leave the Preserve aspect ratio box checked,
           type in one number and the other will be calculated for you.
           Resampling an image often improves its quality, especially
           when enlarging it. Enlarging without resampling can result in
           a blurry image.
           Resampling will not be used often seen that this is used for
           enlarging the image, but Resize will.
           A picture taken with the camera set on the highest resolution
           of 1152*864 pixels, can be Resized by half (50%) and still
           look good on screen and the transmission time of the photo is
           reduced accordingly !
           Even a picture taken with the camera resolution reduced as
           described in IT Tips & Tricks number 1 to 640*480 pixels,
           being about 60Kb, could sometimes be Cropped (see point 2) and
           Resized without loosing much detail.
           Click OK to resize the image. This action can be reversed by
           the Edit menu's Undo command.
     4. 
       Image Menu:
   Decrease Colour Depth
   Click on the Image menu, then select Decrease Colour Depth. A dialog
   shows the possible colour depths. Select one.
   Reducing the colour dept from the original camera picture 24bit colour
   dept (16.7 million colours) to 256 can reduce the file size by approx.
   400 % ! Depending on the compression factor used and the colours in
   the picture.
   Click OK to make the change. This action can be reversed by the Edit
   menu's Undo command.
     5. 
       File Menu – Save as…:
   Increasing the compression factor
   JPEG
   The upper half of this tab lets you set a quality level for JPG
   images. Move the slider control to the desired setting. Lower settings
   take less space, but deliver less quality. Higher settings are better,
   but take more file space. The default setting is 80, which is fine for
   most images.
   Check the greyscale box to save the image as that. Click the Save
   progressive (like many images from internet) box to activate that
   option. Click either again to remove the choice.
   All other picture formats then jpeg as tif, .bmp etc give larger file
   sizes.
   So increasing the compression factor (a lower setting then the default
   of 80) also reduces the file size further, but can compromise the
   quality, but remember that the picture is only to be displayed on
   screen and if it still looks good, increasing the compression can save
   a lot of transmission time.
   Jan Kuiper / ITops
   Amsterdam,
   17 July 2001
   Viewing Pictures with IrfanView
   -------------------------------
   Start IrfanView via the Start button or Desktop icon.
   File Menu
   The following options are available on the File Menu:
     1. 
       Open
       Click on the File menu, then Open (or use the Open tool on the
       toolbar.) A dialog allows you to open a file for use in IrfanView.
       Use the Look in box to locate the file you want, or type a file
       name into File Name. Files of type lets you limit your choice,
       showing only the type of file you want (JPG, for instance.) The
       default is Common IrfanView Files (Windows can't display at same
       time all file types supported by IrfanView).
       If you check Preview active, a single click on an image filename
       will display a small version. Another click brings the file into
       the viewer. You can also double click the filename.
       If multiple images are in the file, as with icons, a small dialog
       box will allow you to choose one. Single click the names for a
       preview. Click accept when you find the one you want.
       To close without opening a file, click Cancel . Another way to
       close is to click the X in the upper right corner.
       After the opening, you will see an image or you will get an error
       message, if the file type is unsupported by IrfanView.
       If you open a large image, you can use scrollbars to see all parts
       of the image. Scrolling is possible with the arrow keys and with
       the page up/down, home/end keys. Scrolling is also possible with
       the right mouse button: press the right mouse button and move the
       mouse around.
       With an image in the viewer, you can manipulate it in a large
       number of ways. Most functions for changing an image are in the
       Edit and Image menus.
       When you are finished with the image, Save it to your disk. Bring
       in another image, or Exit IrfanView.
     2. 
       Thumbnails (Viewing your pictures)
       Open an image from a selected directory in the viewer. (Pictures
       taken with the camera are located on the E: drive when the memory
       card of the camera is inserted in the SanDisk reader). Click the
       File menu, then Thumbnails. A box will open and fill with
       thumbnails of the images in the directory.
       On the left side is a tree view with drives and directories.
       Double click any thumbnail to open that image in the viewer. If
       you change directories by opening another image, the thumbnail
       display will show those images.
       To close the display, click Exit on the display's menu bar or
       press ESC.
       Menu:
       a. 
         File:
         Copy selected files: allows you to copy all selected thumbs
         (files) to another directory.
         Move selected files: allows you to move all selected thumbs
         (files) to another directory.
         Delete selected files: allows you to delete all selected thumbs
         (files).
         Start slideshow with selected thumbs: Click to start slideshow
         with all selected thumbs (files) and current slideshow settings.
         Save selected thumbs as an image. Click to have your selected
         thumbs made into a single image and saved. A dialog lets you
         choose the directory to save the image in. Images are selected
         by clicking on each thumb, while holding down the CTRL key, or
         by using the Select All option (see above.)
         Save selected thumbs as HTML file. Click to make a page of
         thumbs that can be used in a web browser, or at an internet
         website. A dialog lets you choose the directory to save the file
         in. Images are selected by clicking on each thumb, while holding
         down the CTRL key, or by using the Select All option (see
         above.) If you already chose the option Copy original images to
         same directory like HTML file, the actual images will also be
         copied to the directory.
         Save selected thumbs as single images. Click to have chosen
         thumbs made into images and saved individually. A dialog lets
         you choose the directory to save them in. Images are selected by
         clicking on each thumb, while holding down the CTRL key, or by
         using the Select All option (see above.)
         Print selected thumbs as single images. Click to print all
         selected images (batch printing). Images are selected by
         clicking on each thumb, while holding down the CTRL key, or by
         using the Select All option (see above.)
         Open with external editor. Click to have an alternate viewing or
         editing program opened, with the image connected to the current
         thumbnail displayed in it. To use this option, you must first
         set up an external editor.
       b. 
         Options:
         Save current size/position will save the actual size/position of
         the Thumbnail window. You can resize/move the Thumbnail window
         manually with mouse.
         Select All highlights all the thumbs for saving them as files
         (below.)
         Set thumbnail options lets you control the size and quality of
         the thumbnails. Click it to open a dialog box. The first option
         is Use Resample instead of Resize for creating thumbnails. Click
         the check-box to have better quality thumbnails displayed. This
         may take longer for the images to appear. The next option is
         Thumbnail size. Click one of the option buttons to set a size
         for the thumbnails. The default is 80 x 80 pixels.
         The next option is Copy original images to same directory like
         HTML file. Check the box; when you save thumbs as an HTML file,
         the images themselves will be copied to the directory you chose.
         The thumbnail window can remember several directories with
         thumbnails. If you click Write file name/size for thumbnail
         links, you will see additional information for each thumbnail on
         the HTML page.
       c. 
         View:
         Directory tree will hide/show the directory tree on the left
         side of thumbnail window
       d. 
         You can Set the number of the MRUDs 1. If you want to clear the
         MRUD list, press the Clear MRUDs button. When done making your
         choices, click OK to exit. Click Cancel to exit without making
         any changes.
   1 MRUDs
   On the File menu, point the mouse at MRUDs (most recently used
   directories). A sub-menu appears showing the most recently used
   directories. Click one, and the Open dialog appears, already in the
   chosen directory. From there you can open any file in the directory.
   The MRUDs list can be erased using a button on the Others 1 tab,
   located in the Properties box, on the Options menu.
   IT Tips and Tricks – no. 2 page: 2
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